use strict;
my $str = 'str test = "ee";
call $std:console.print(test);
call $std:window.resize(1280, 720);
call test("test");';
my $regex = qr/((\$?[A-Za-z_][A-Za-z_0-9.]*):)?([A-Za-z_][A-Za-z_0-9.]*)\(((.*,)*(.*))\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}