re = /(^\w+\#([^\/]+)|(^[^(#|\/)]+$))/m
str = 'usuario
usuario#Meus Arquivos
usuario#Meus Arquivos/Pasta1
usuario#Meus Arquivos/Pasta1#
usuario#Meus Arquivos/Pasta1#ComIsso
#Meus Arquivos
#Meus Arquivos/Pasta1
#Meus Arquivos/Pasta1#
#Meus Arquivos/Pasta1#ComIsso
Meus Arquivos
Meus Arquivos/Pasta1
Meus Arquivos/Pasta1#
Meus Arquivos/Pasta1#ComIsso
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end