package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^\w+\#([^\/]+)|(^[^(#|\/)]+$))`)
var str = `usuario
usuario#Meus Arquivos
usuario#Meus Arquivos/Pasta1
usuario#Meus Arquivos/Pasta1#
usuario#Meus Arquivos/Pasta1#ComIsso
#Meus Arquivos
#Meus Arquivos/Pasta1
#Meus Arquivos/Pasta1#
#Meus Arquivos/Pasta1#ComIsso
Meus Arquivos
Meus Arquivos/Pasta1
Meus Arquivos/Pasta1#
Meus Arquivos/Pasta1#ComIsso
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}