const regex = /(^\w+\#([^\/]+)|(^[^(#|\/)]+$))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^\\w+\\#([^\\\/]+)|(^[^(#|\\\/)]+$))', 'gm')
const str = `usuario
usuario#Meus Arquivos
usuario#Meus Arquivos/Pasta1
usuario#Meus Arquivos/Pasta1#
usuario#Meus Arquivos/Pasta1#ComIsso
#Meus Arquivos
#Meus Arquivos/Pasta1
#Meus Arquivos/Pasta1#
#Meus Arquivos/Pasta1#ComIsso
Meus Arquivos
Meus Arquivos/Pasta1
Meus Arquivos/Pasta1#
Meus Arquivos/Pasta1#ComIsso
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}