use strict;
my $str = '<ul class="secondary">
<li><a href="/all/">all code snippets</a>/</li>
<li><a href="/popular/">popular code snippets</a>/</li>
<li><a href="/yours/">your code snippets</a></li>
</ul>
</li>
<li class="developer">
<a href="/developer/">extras</a>
</li>
<li class="blog"><a href="/blog/">blog</a></li>
<li class="about"><a href="/about/">about snipplr</a></li>
</ul>
</div>
</div>
</div>
<div id="subnav">
<div class="container">
<div id="switcher">
<span>Change style:</span>
<ul>
<li><a class="styleswitch" href="#" onclick="setActiveStyleSheet(\'big\'); return false;">Big</a> / </li>
<li><a class="styleswitch" href="#" onclick="setActiveStyleSheet(\'small\'); return false;">Small</a></li>';
my $regex = qr/\bcontainer\W+(?:\w+\W+){1,6}?switcher\b/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}