const regex = new RegExp('\\bcontainer\\W+(?:\\w+\\W+){1,6}?switcher\\b', 'g')
const str = `<ul class="secondary">
<li><a href="/all/">all code snippets</a>/</li>
<li><a href="/popular/">popular code snippets</a>/</li>
<li><a href="/yours/">your code snippets</a></li>
</ul>
</li>
<li class="developer">
<a href="/developer/">extras</a>
</li>
<li class="blog"><a href="/blog/">blog</a></li>
<li class="about"><a href="/about/">about snipplr</a></li>
</ul>
</div>
</div>
</div>
<div id="subnav">
<div class="container">
<div id="switcher">
<span>Change style:</span>
<ul>
<li><a class="styleswitch" href="#" onclick="setActiveStyleSheet('big'); return false;">Big</a> / </li>
<li><a class="styleswitch" href="#" onclick="setActiveStyleSheet('small'); return false;">Small</a></li>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}