import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bcontainer\\W+(?:\\w+\\W+){1,6}?switcher\\b";
final String string = "<ul class=\"secondary\">\n"
+ "<li><a href=\"/all/\">all code snippets</a>/</li>\n"
+ "<li><a href=\"/popular/\">popular code snippets</a>/</li>\n"
+ "<li><a href=\"/yours/\">your code snippets</a></li>\n"
+ "</ul>\n"
+ "</li>\n"
+ "<li class=\"developer\">\n"
+ "<a href=\"/developer/\">extras</a>\n"
+ "</li>\n"
+ "<li class=\"blog\"><a href=\"/blog/\">blog</a></li>\n"
+ "<li class=\"about\"><a href=\"/about/\">about snipplr</a></li>\n"
+ "</ul>\n"
+ "</div>\n"
+ "</div>\n"
+ "</div>\n"
+ "<div id=\"subnav\">\n"
+ "<div class=\"container\">\n"
+ "<div id=\"switcher\">\n"
+ "<span>Change style:</span>\n"
+ "<ul>\n"
+ "<li><a class=\"styleswitch\" href=\"#\" onclick=\"setActiveStyleSheet('big'); return false;\">Big</a> / </li>\n"
+ "<li><a class=\"styleswitch\" href=\"#\" onclick=\"setActiveStyleSheet('small'); return false;\">Small</a></li>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}