re = /((\d+)(?=\/))(?!.*\1)/m
str = '/designer-dev/22/Staging/Datawatch/English/hotfix/22.1.4/InternalBuild/1.2.3.44/AltairPanopticonVisualizationServerWAR_22-1-4.zip'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end