use strict;
my $str = '/designer-dev/22/Staging/Datawatch/English/hotfix/22.1.4/InternalBuild/1.2.3.44/AltairPanopticonVisualizationServerWAR_22-1-4.zip';
my $regex = qr/((\d+)(?=\/))(?!.*\1)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}