import Foundation
let pattern = #"^([A-Za-z./:/\-\(\=><) ]+(?<!PRESENT\b)(?<!ABSENT\b)(?<!NORMAL\b)(?<!POSITIVE\b)(?<!NEGATIVE\b)(?<!TRACE\b)) +?(ABSENT|PRESENT|NORMAL|TRACE|POSITIVE|NEGATIVE|\"[A-Z]\")+? *?([\(\+\) ]*) *?(Absent|Normal|Present|Trace|Positive|Negative)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
Deposit : ABSENT
Bile Pigments : Negative NEGATIVE
ABO And RhD Typing : A positive positive
Albumin : Negative NEGATIVE asdasd
Mucus : PRESENT
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)