const regex = new RegExp('^([A-Za-z./:/\\-\\(\\=><) ]+(?<!PRESENT\\b)(?<!ABSENT\\b)(?<!NORMAL\\b)(?<!POSITIVE\\b)(?<!NEGATIVE\\b)(?<!TRACE\\b)) +?(ABSENT|PRESENT|NORMAL|TRACE|POSITIVE|NEGATIVE|\\"[A-Z]\\")+? *?([\\(\\+\\) ]*) *?(Absent|Normal|Present|Trace|Positive|Negative)?$', 'gmi')
const str = `
Deposit : ABSENT
Bile Pigments : Negative NEGATIVE
ABO And RhD Typing : A positive positive
Albumin : Negative NEGATIVE asdasd
Mucus : PRESENT
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}