use strict;
my $str = '
Deposit : ABSENT
Bile Pigments : Negative NEGATIVE
ABO And RhD Typing : A positive positive
Albumin : Negative NEGATIVE asdasd
Mucus : PRESENT
';
my $regex = qr/^([A-Za-z./:/\-\(\=><) ]+(?<!PRESENT\b)(?<!ABSENT\b)(?<!NORMAL\b)(?<!POSITIVE\b)(?<!NEGATIVE\b)(?<!TRACE\b)) +?(ABSENT|PRESENT|NORMAL|TRACE|POSITIVE|NEGATIVE|\"[A-Z]\")+? *?([\(\+\) ]*) *?(Absent|Normal|Present|Trace|Positive|Negative)?$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}