re = /(?<value1>.*?)<a.*?href=("|')(?<href>.*?)("|').*?>(?<value2>.*?)<\/a>(?<value3>.*?)/
str = 'foo<a href="foo">bar</a>foo bar baz'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end