$re = '~(?<value1>.*?)<a.*?href=("|\')(?<href>.*?)("|\').*?>(?<value2>.*?)</a>(?<value3>.*?)~';
$str = 'foo<a href="foo">bar</a>foo bar baz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);