package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<value1>.*?)<a.*?href=("|')(?<href>.*?)("|').*?>(?<value2>.*?)</a>(?<value3>.*?)`)
var str = `foo<a href="foo">bar</a>foo bar baz`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}