$re = '/\$\{\w+?\}|%\(\w+?\)s|<%=\w+?%>/';
$str = 'foobar ${name} barfoo ${name2} or ${ name3 } foobar {no} 50% off of $50 foobar {${name}} barfoo {${name2}} or { ${ name3 } } foobar {no} 50% off of $50
foobar %(name)s barfoo %(name2)s or %( name2 )s foobar {no} 50% off of ($50)
foobar <%=name%> barfoo <%=name2%> or <%= name3 %> foobar {no} 50% off of $50 <element>here</element> there
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);