package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\$\{\w+?\}|%\(\w+?\)s|<%=\w+?%>`)
var str = `foobar ${name} barfoo ${name2} or ${ name3 } foobar {no} 50% off of $50 foobar {${name}} barfoo {${name2}} or { ${ name3 } } foobar {no} 50% off of $50
foobar %(name)s barfoo %(name2)s or %( name2 )s foobar {no} 50% off of ($50)
foobar <%=name%> barfoo <%=name2%> or <%= name3 %> foobar {no} 50% off of $50 <element>here</element> there
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}