use strict;
my $str = 'foobar ${name} barfoo ${name2} or ${ name3 } foobar {no} 50% off of $50 foobar {${name}} barfoo {${name2}} or { ${ name3 } } foobar {no} 50% off of $50
foobar %(name)s barfoo %(name2)s or %( name2 )s foobar {no} 50% off of ($50)
foobar <%=name%> barfoo <%=name2%> or <%= name3 %> foobar {no} 50% off of $50 <element>here</element> there
';
my $regex = qr/\$\{\w+?\}|%\(\w+?\)s|<%=\w+?%>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}