re = /if \(([^\$]+\$\<\>[^ ]+)[^\}]+\(null, ([^;]+)\);\s+}\s+([^;]+)\1(.*;)/
str = 'get
{
int num;
lock (this.queueLock)
{
if (Journal.CS$<>9__CachedAnonymousMethodDelegate7 == null)
{
Journal.CS$<>9__CachedAnonymousMethodDelegate7 = new Func<ApiBlob, int>(null, (ApiBlob blob) => Encoding.UTF8.GetByteCount(blob.DataString));
}
num = this.Sum<ApiBlob>(Journal.CS$<>9__CachedAnonymousMethodDelegate7);
}
return num;
}
}'
subst = '\\3\\2\\4'
result = str.sub(re, subst)
# Print the result of the substitution
puts result