# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/if \(([^\$]+\$\<\>[^ ]+)[^\}]+\(null, ([^;]+)\);\s+}\s+([^;]+)\1(.*;)/\3\2\4/;t' <<< "get
{
int num;
lock (this.queueLock)
{
if (Journal.CS$<>9__CachedAnonymousMethodDelegate7 == null)
{
Journal.CS$<>9__CachedAnonymousMethodDelegate7 = new Func<ApiBlob, int>(null, (ApiBlob blob) => Encoding.UTF8.GetByteCount(blob.DataString));
}
num = this.Sum<ApiBlob>(Journal.CS$<>9__CachedAnonymousMethodDelegate7);
}
return num;
}
}"