using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"if \(([^\$]+\$\<\>[^ ]+)[^\}]+\(null, ([^;]+)\);\s+}\s+([^;]+)\1(.*;)";
string substitution = @"\3\2\4";
string input = @"get
{
int num;
lock (this.queueLock)
{
if (Journal.CS$<>9__CachedAnonymousMethodDelegate7 == null)
{
Journal.CS$<>9__CachedAnonymousMethodDelegate7 = new Func<ApiBlob, int>(null, (ApiBlob blob) => Encoding.UTF8.GetByteCount(blob.DataString));
}
num = this.Sum<ApiBlob>(Journal.CS$<>9__CachedAnonymousMethodDelegate7);
}
return num;
}
}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}