re = /{myplugin:start=(.*):.*stop=(.*)}(.*){\/myplugin}/m
str = '{myplugin:start=2023-02-01:stop=2024-02-02}contenu {/myplugin}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end