$re = '/{myplugin:start=(.*):.*stop=(.*)}(.*){\/myplugin}/m';
$str = '{myplugin:start=2023-02-01:stop=2024-02-02}contenu {/myplugin}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);