const regex = /{myplugin:start=(.*):.*stop=(.*)}(.*){\/myplugin}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('{myplugin:start=(.*):.*stop=(.*)}(.*){\\\/myplugin}', 'gm')
const str = `{myplugin:start=2023-02-01:stop=2024-02-02}contenu {/myplugin}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}