re = /\[[^\]]*\]/m
str = '[caption id=“attachment_2833” align=“aligncenter” width=“600”] IL MIO TESTO DA TENERE [/caption]
[caption id=“attachment_2833” align=“aligncenter” width=“600”] text1 [/caption]
[caption id=“attachment_2833” align=“aligncenter” width=“600”] text2 [/caption]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end