using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[[^\]]*\]";
string input = @"[caption id=“attachment_2833” align=“aligncenter” width=“600”] IL MIO TESTO DA TENERE [/caption]
[caption id=“attachment_2833” align=“aligncenter” width=“600”] text1 [/caption]
[caption id=“attachment_2833” align=“aligncenter” width=“600”] text2 [/caption]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}