$re = '/\[[^\]]*\]/m';
$str = '[caption id=“attachment_2833” align=“aligncenter” width=“600”] IL MIO TESTO DA TENERE [/caption]
[caption id=“attachment_2833” align=“aligncenter” width=“600”] text1 [/caption]
[caption id=“attachment_2833” align=“aligncenter” width=“600”] text2 [/caption]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);