re = /'((?:\\.|[^'])*+)'/m
str = '\'hello world\'
\'here\\\'s my foo\'
\'I\\\'m at my friends\\\'
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end