package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)'((?:\\.|[^'])*+)'`)
var str = `'hello world'
'here\'s my foo'
'I\'m at my friends\'
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}