$re = '/\'((?:\\\\.|[^\'])*+)\'/m';
$str = '\'hello world\'
\'here\\\'s my foo\'
\'I\\\'m at my friends\\\'
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);