$re = '/(\W?Receiver\W)(?P<receiver>\d+)(\Wfor abonent\W)(?P<abonent>[a-f0-9]{8}-[a-f0-9]{4}-4[a-f0-9]{3}-[89aAbB][a-f0-9]{3}-[a-f0-9]{12})(\Wunregistered\W?)/';
$str = 'Receiver 7701 for abonent 9acc86c1-f690-406a-96b6-25ab3796b8dd unregistered';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);