use strict;
my $str = 'Receiver 7701 for abonent 9acc86c1-f690-406a-96b6-25ab3796b8dd unregistered';
my $regex = qr/(\W?Receiver\W)(?P<receiver>\d+)(\Wfor abonent\W)(?P<abonent>[a-f0-9]{8}-[a-f0-9]{4}-4[a-f0-9]{3}-[89aAbB][a-f0-9]{3}-[a-f0-9]{12})(\Wunregistered\W?)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}