#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\W?Receiver\W)(?P<receiver>\d+)(\Wfor abonent\W)(?P<abonent>[a-f0-9]{8}-[a-f0-9]{4}-4[a-f0-9]{3}-[89aAbB][a-f0-9]{3}-[a-f0-9]{12})(\Wunregistered\W?)"
Local $sString = "Receiver 7701 for abonent 9acc86c1-f690-406a-96b6-25ab3796b8dd unregistered"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")