re = /(Property\sname:(\w+))/m
str = 'Property:0x21207642, Property name:DI_INFO_SAFETY_WARNINGS_WARNING_SLIPPERY_CONDITIONS, access:0x1, changeMode:0x1, config:0x[], fs min:0.0, fs max:0.0
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end