package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(Property\sname:(\w+))`)
var str = `Property:0x21207642, Property name:DI_INFO_SAFETY_WARNINGS_WARNING_SLIPPERY_CONDITIONS, access:0x1, changeMode:0x1, config:0x[], fs min:0.0, fs max:0.0
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}