use strict;
my $str = 'Property:0x21207642, Property name:DI_INFO_SAFETY_WARNINGS_WARNING_SLIPPERY_CONDITIONS, access:0x1, changeMode:0x1, config:0x[], fs min:0.0, fs max:0.0
';
my $regex = qr/(Property\sname:(\w+))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}