const regex = new RegExp('test(.+)test', 'g')
const str = `testfoobartest`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);