package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`test(.+)test`)
var str = `testfoobartest`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}