using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"test(.+)test";
string substitution = @"\1";
string input = @"testfoobartest";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}