$re = '~[+-]?(?:\d+(?:\.\d+)?|\([ \t]*(?R)[ \t]*\)) (?:[ \t]*[*+/-][ \t]* [+-]?(?:\d+(?:\.\d+)?|\([ \t]*(?R)[ \t]*\)))*~x';
$str = '( (1 + 0.2) * 2) * (-(1 + (2 - 3) ) - -16), 6 + 3 , -6 * (1+2) , 6 * -(1+2), 12.23 , (23.34) ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);