using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[+-]?(?:\d+(?:\.\d+)?|\([ \t]*(?R)[ \t]*\)) (?:[ \t]*[*+/-][ \t]* [+-]?(?:\d+(?:\.\d+)?|\([ \t]*(?R)[ \t]*\)))*";
string input = @"( (1 + 0.2) * 2) * (-(1 + (2 - 3) ) - -16), 6 + 3 , -6 * (1+2) , 6 * -(1+2), 12.23 , (23.34) ";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}