const regex = new RegExp('[+-]?(?:\\d+(?:\\.\\d+)?|\\([ \\t]*(?R)[ \\t]*\\)) (?:[ \\t]*[*+/-][ \\t]* [+-]?(?:\\d+(?:\\.\\d+)?|\\([ \\t]*(?R)[ \\t]*\\)))*', 'g')
const str = `( (1 + 0.2) * 2) * (-(1 + (2 - 3) ) - -16), 6 + 3 , -6 * (1+2) , 6 * -(1+2), 12.23 , (23.34) `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}