import Foundation
let pattern = #"^\s*access-list\s+(\d+)\s*$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
permit tcp 172.16.0.0/12 10.14.0.21/32 eq 80 log
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}