using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*access-list\s+(\d+)\s*$";
string input = @" permit tcp 172.16.0.0/12 10.14.0.21/32 eq 80 log
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}