const regex = /^\s*access-list\s+(\d+)\s*$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*access-list\\s+(\\d+)\\s*$', '')
const str = ` permit tcp 172.16.0.0/12 10.14.0.21/32 eq 80 log
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}