import Foundation
let pattern = #"(?<=gps.longitude)(\s*)(:\s)(?<lon>.*)\n.*(?<=gps.latitude)(\s*)(:\s)(?<lat>.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
modem.location.3gpp.mcc : 310
modem.location.3gpp.mnc : 260
modem.location.3gpp.lac : FFFE
modem.location.3gpp.tac : 7D84
modem.location.3gpp.cid : 027A6B84
modem.location.gps.nmea.length : 5
modem.location.gps.nmea.value[1] : $GPGSA,A,2,08,10,18,22,24,32,,,,,,,1.2,0.9,0.8*36
modem.location.gps.nmea.value[2] : $GPRMC,194501.0,A,2947.759106,N,09534.022631,W,0.0,0.0,090922,3.2,E,A*15
modem.location.gps.nmea.value[3] : $GPGSV,3,1,10,08,09,303,31,10,53,343,29,15,02,053,19,18,43,147,26*71\r\n$GPGSV,3,2,10,22,31,239,31,24,34,057,29,27,23,268,21,31,00,196,19*76\r\n$GPGSV,3,3,10,32,55,260,22,46,,,34*48
modem.location.gps.nmea.value[4] : $GPVTG,0.0,T,356.8,M,0.0,N,0.0,K,A*2B
modem.location.gps.nmea.value[5] : $GPGGA,194501.0,2947.759106,N,09534.022631,W,1,06,0.9,28.1,M,-21.0,M,,*57
modem.location.gps.utc : 194501.0
modem.location.gps.longitude : -95.567044
modem.location.gps.latitude : 29.795985
modem.location.gps.altitude : 28.100000
modem.location.cdma-bs.longitude : --
modem.location.cdma-bs.latitude : --
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)