const regex = /(?<=gps.longitude)(\s*)(:\s)(?<lon>.*)\n.*(?<=gps.latitude)(\s*)(:\s)(?<lat>.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=gps.longitude)(\\s*)(:\\s)(?<lon>.*)\\n.*(?<=gps.latitude)(\\s*)(:\\s)(?<lat>.*)', 'gm')
const str = `modem.location.3gpp.mcc : 310
modem.location.3gpp.mnc : 260
modem.location.3gpp.lac : FFFE
modem.location.3gpp.tac : 7D84
modem.location.3gpp.cid : 027A6B84
modem.location.gps.nmea.length : 5
modem.location.gps.nmea.value[1] : \$GPGSA,A,2,08,10,18,22,24,32,,,,,,,1.2,0.9,0.8*36
modem.location.gps.nmea.value[2] : \$GPRMC,194501.0,A,2947.759106,N,09534.022631,W,0.0,0.0,090922,3.2,E,A*15
modem.location.gps.nmea.value[3] : \$GPGSV,3,1,10,08,09,303,31,10,53,343,29,15,02,053,19,18,43,147,26*71\\r\\n\$GPGSV,3,2,10,22,31,239,31,24,34,057,29,27,23,268,21,31,00,196,19*76\\r\\n\$GPGSV,3,3,10,32,55,260,22,46,,,34*48
modem.location.gps.nmea.value[4] : \$GPVTG,0.0,T,356.8,M,0.0,N,0.0,K,A*2B
modem.location.gps.nmea.value[5] : \$GPGGA,194501.0,2947.759106,N,09534.022631,W,1,06,0.9,28.1,M,-21.0,M,,*57
modem.location.gps.utc : 194501.0
modem.location.gps.longitude : -95.567044
modem.location.gps.latitude : 29.795985
modem.location.gps.altitude : 28.100000
modem.location.cdma-bs.longitude : --
modem.location.cdma-bs.latitude : --`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}