# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=gps.longitude)(\s*)(:\s)(?<lon>.*)\n.*(?<=gps.latitude)(\s*)(:\s)(?<lat>.*)"
test_str = ("modem.location.3gpp.mcc : 310\n"
"modem.location.3gpp.mnc : 260\n"
"modem.location.3gpp.lac : FFFE\n"
"modem.location.3gpp.tac : 7D84\n"
"modem.location.3gpp.cid : 027A6B84\n"
"modem.location.gps.nmea.length : 5\n"
"modem.location.gps.nmea.value[1] : $GPGSA,A,2,08,10,18,22,24,32,,,,,,,1.2,0.9,0.8*36\n"
"modem.location.gps.nmea.value[2] : $GPRMC,194501.0,A,2947.759106,N,09534.022631,W,0.0,0.0,090922,3.2,E,A*15\n"
"modem.location.gps.nmea.value[3] : $GPGSV,3,1,10,08,09,303,31,10,53,343,29,15,02,053,19,18,43,147,26*71\\r\\n$GPGSV,3,2,10,22,31,239,31,24,34,057,29,27,23,268,21,31,00,196,19*76\\r\\n$GPGSV,3,3,10,32,55,260,22,46,,,34*48\n"
"modem.location.gps.nmea.value[4] : $GPVTG,0.0,T,356.8,M,0.0,N,0.0,K,A*2B\n"
"modem.location.gps.nmea.value[5] : $GPGGA,194501.0,2947.759106,N,09534.022631,W,1,06,0.9,28.1,M,-21.0,M,,*57\n"
"modem.location.gps.utc : 194501.0\n"
"modem.location.gps.longitude : -95.567044\n"
"modem.location.gps.latitude : 29.795985\n"
"modem.location.gps.altitude : 28.100000\n"
"modem.location.cdma-bs.longitude : --\n"
"modem.location.cdma-bs.latitude : --")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.