import Foundation
let pattern = #"^(?:https):\/\/paypal\.me\/.+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://www.paypal.com
https://paypal.me/sendmerimoneynow?locale.x=en_GB
https://paypal.me/s/fjldj
http://paypal.me/fldjfskj
https://www.paypal.com/us/smarthelp/article/what-is-paypal.me-faq3025
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)