$re = '/^(?:https):\/\/paypal\.me\/.+/m';
$str = 'http://www.paypal.com
https://paypal.me/sendmerimoneynow?locale.x=en_GB
https://paypal.me/s/fjldj
http://paypal.me/fldjfskj
https://www.paypal.com/us/smarthelp/article/what-is-paypal.me-faq3025';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);